uva 10042 smith numbers

  Problem D: Smith Numbers 

Background 

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University , noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 

\begin{displaymath}4937775 = 3\cdot 5\cdot 5\cdot 65837\end{displaymath}

The sum of all digits of the telephone number is  4+9+3+7+7+7+5=42, and the sum of the digits of its prime factors is equally  3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this type of numbers after his brother-in-law: Smith numbers.

As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number and he excluded them from the definition.

Problem 

Wilansky published an article about Smith numbers in the  Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However, Wilansky was not able to give a Smith number which was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers which are larger than 4937775.

Input 

The input consists of several test cases, the number of which you are given in the first line of the input.

Each test case consists of one line containing a single positive integer smaller than 109.

Output 

For every input value  n , you are to compute the smallest Smith number which is larger than  n  and print each number on a single line. You can assume that such a number exists.

Sample Input 

1
4937774

Sample Output 

4937775



Miguel Revilla 
2000-11-19


枚举


#include <cstdio>
#include <cstdlib>
#include <cassert>
#include <cstring>

#ifndef ONLINE_JUDGE
#define debug_printf(...) (printf(__VA_ARGS__))
#else
#define debug_printf(...) (0)
#endif

const int PRIME_SZ_MAX = 32 * 32 * 32 * 2;

bool is_prime[PRIME_SZ_MAX];

int prime[PRIME_SZ_MAX / 2];
int prime_sz;

void generate_primes()
{
    memset (is_prime, 1, sizeof(is_prime));
    for (int i=2; i<PRIME_SZ_MAX; ++i) {
        for (int k=i+i; is_prime[i] && k<PRIME_SZ_MAX; k+=i) {
            is_prime[k] = false;
        }
    }

    prime_sz = 0;
    for (int i=2; i<PRIME_SZ_MAX; ++i) {
        if (is_prime[i]) {
            assert (prime_sz + 1 <= PRIME_SZ_MAX / 2);
            prime[prime_sz++] = i;
        }
    }
}

int sum_digits (int n)
{
    int sum = 0;
    while (n) {
        sum += n % 10;
        n /= 10;
    }
    return sum;
}

int sum_prime_factors_digits (int n)
{
    int sum = 0;
    int p = 0;
    while (n > 1) {
        if (n % prime[p] == 0) {
            sum += sum_digits (prime[p]);
            n /= prime[p];
        } else if (p + 1 < prime_sz) {
            ++p;
        } else {
            sum += sum_digits (n);
            n = 1;
        }
    }
    return sum;
}

bool f_is_prime (int n)
{
    if (n <= 1) {
        return false;
    }

    if (n < PRIME_SZ_MAX) {
        return is_prime[n];
    }

    for (int i=0; i<prime_sz; ++i) {
        if (n % prime[i] == 0) {
            return false;
        } else if (prime[i] * prime[i] > n) {
            return true;
        }
    }

    return true;
}

void solve_a_case()
{
    int n;
    if (scanf ("%d", &n) == EOF) {
        exit (0);
    }

    while (true) {
        ++n;
        assert (n > 0);
        if (!f_is_prime (n) && sum_digits (n) == sum_prime_factors_digits (n)) {
            printf ("%d\n", n);
            break;
        }
    }
}

int main (int argc, char **argv)
{
    generate_primes();
    debug_printf ("%d primes generated\n", prime_sz);

    int cs;
    scanf ("%d", &cs);
    while (cs-- > 0) {
        solve_a_case();
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值