POJ1144(割点入门题)

Network
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15900 Accepted: 7182

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

Source

Central Europe 1996

你只要记住::(剩下的代码中解释)

1.如果点v是DFS序列的根节点,则如果v有一个以上的孩子,则v是一个割点。

2.如果v不是DFS序列根节点,并且点v的任意后继u能追溯到最早的祖先节点low[u]>=dfn[v],则v是一个割点。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
struct fuck
{
	int to, ne;
}es[10005];
int head[100];
int e;
void add(int u, int v)
{
	es[e].to = v;
	es[e].ne = head[u];
	head[u] = e++;
}
int root;
int ans;
int dfn[105];
int low[105];//最早返祖节点;
int vis[105];
int ar[105];
int time;
void tarjan(int u, int fa)
{
	int son = 0; //子孙数量
	vis[u] = 1;//标记已经被访问过
	dfn[u] = low[u] = ++time;
	for (int s = head[u]; ~s; s = es[s].ne)
	{
		int v = es[s].to;//找到子孙节点;
		if (!vis[v])//如果这个不是曾经的祖宗
		{
			tarjan(v, u);//遍历
			son++;//子孙++
			low[u] = min(low[u], low[v]);//如果子孙能够回溯到更早的~~那么父亲辈的他也行~~
			if (u == root&&son > 1 || u != root&&dfn[u] <= low[v])//如之前所言~
			{
				ar[u] = 1;
			}
		}
		if (vis[v] && v != fa)
		{
			low[u] = min(low[u], dfn[v]);
		}
	}
}
int main()
{
	int n;
	while (~scanf("%d", &n) && n)
	{
		memset(vis, 0, sizeof(vis));
		memset(head, -1, sizeof(head));
		memset(dfn, 0, sizeof(dfn));
		memset(low, 0, sizeof(low));
		memset(ar, 0, sizeof(ar));
		e = 0;
		time = 0;
		ans = 0;
		int u, v;
		while (scanf("%d", &u) && u)
		{
			while (getchar() != '\n')
			{
				scanf("%d", &v);
				add(u, v);
				add(v, u);
			}
		}
		root = 1;
		tarjan(root, -1);
		int ans=0;
		for (int s = 1; s <= n; s++)
		{
			if (ar[s])
			{
				ans++;
			}
		}
		cout << ans << endl;
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值