【ZOJ - 3870 Team Formation】 异或运算

B - Team Formation


For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{AB}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ithinteger denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input
2
3
1 2 3
5
1 2 3 4 5
Sample Output
1
6


题意:在给定的一组数据中,找到符合两数的异或值大于这两数中最大值条件的数字对,求存在多少组这样的数字对。


分析:直接两两一组地找肯定会TLE。我们想,要一个数变大,只要这个数的二进制中有一个0变为了1,那么这个数一定会变大。那么我们可以记录每个数二进制中1所在的位数,但是我们想一想,如果两个数二进制中有0变为了1,但他们的高位却都有1,这样数反而会变小。

例如:10001 ^ 11111 = 01110

所以我们要记录的1的所在位数,就必须为那个数的最高位1,这样就不会发生上述情况。具体可以看看代码。


代码如下:

#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>

#define mod 835672545
#define LL long long
#define INF 0x3f3f3f3f

using namespace std;
const int MX = 1e5 + 5;
int a[MX];
int num[MX];

int main() {
    int t;
    scanf("%d", &t);
    while(t--){
        int n;
        scanf("%d", &n);
        memset(num, 0, sizeof(num));
        for(int i = 0; i < n; i++){
            scanf("%d", &a[i]);
            for(int j = 31; j >= 0; j--){
                if((a[i] >> j) & 1){
                    num[j]++;
                    break;
                }
            }
        }
        int ans = 0;
        for(int i = 0; i < n; i++){
            int k = 0;
            while(a[i] > 0){
                if(!(a[i] & 1)){
                    ans += num[k];
                }
                a[i] >>= 1;
                k++;
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值