1002 A+B for Polynomials (25)

1002 A+B for Polynomials (25)
This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 a~N1~ N2 a~N2~ … NK a~NK~, where K is the number of nonzero terms in the polynomial, Ni and a~Ni~ (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 2 1.5 1 2.9 0 3.2

解题思路:
计算多项式的和。
1.用数组下表表示指数,值表示系数,根据题目要求指数《=1000,所以数组最小要开到1001。
2.数组赋初值0.0,第一行可以直接读入,第二行输入可能与第一行的值相加,用+=。
3.遍历数组,计算非零项个数,先输出。再从后往前,指数大的先输出。注意保留一位小数。

#include<cstdio>
const int maxn=1001;
int main(){
    int k,a;
    double b,ans[maxn]={0.0};
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d%lf",&a,&b);
        ans[a]=b;
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        scanf("%d%lf",&a,&b);
        ans[a]+=b;
    }
    int cnt=0;
    for(int i=0;i<maxn;i++){
        if(ans[i]!=0.0)
            cnt++;
    }
    printf("%d",cnt);
    for(int i=maxn-1;i>=0;i--){
        if(ans[i]!=0.0)
            printf(" %d %.1lf",i,ans[i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值