1005 Spell It Right (20)

1005 Spell It Right (20)
Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345
Sample Output:

one five
解题思路:
1.先用字符串读取,转化为int型的sum。
2.依次将sum的每一位放入ans数组,要注意用do……while,否则特例0会没有输出。或者先特判0,再用while循环,顺便计算位数cnt。
3.从cnt-1倒叙输出每位对应的单词,注意末尾空格。

#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;
const int maxn=110;
char change[10][10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int func1(char str[]){
    int len=strlen(str) ,sum=0;
    for(int i=0;i<len;i++){
        sum+=str[i]-'0';
    }
    return sum;
}

int main(){
    char str[maxn];
    scanf("%s",str);
    int sum=func1(str);
    int cnt=0,ans[maxn];
    do{                     //要写do……while,否则有一个点过不去 
        ans[cnt++]=sum%10;
        sum=sum/10;
    }while(sum);
    for(int i=cnt-1;i>=0;i--){
        printf("%s",change[ans[i]]);
        if(i>0) printf(" ");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值