The sum problem
Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16596 Accepted Submission(s): 4958
Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
Sample Input
20 10 50 30 0 0
Sample Output
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
当我看到数据可以达到1000000000时,就无力吐槽了...用暴力的方法明显会超时,要换位思考。杭电这个题目给的数据感觉还是有用的,第二个测试数据就是按序列长度递减排序的,我们可以用这个思想解决这道题。最大序列长度l=sqrt(2*m),高斯公式推导...
#include<stdio.h>
#include<math.h>
int main()
{
int n,m,i,j,l;
while(scanf("%d%d",&n,&m)&&(n!=0||m!=0))
{
for(l=sqrt(2*m);l>=1;--l)//在(--l和l--)通用时,--l比l--省时间(学长告诉我的...)
{
i=(2*m/l-l+1)/2;//(-l+1)是为了考虑序列长度为一的情况
j=(i+l-1);
if((j+i)*l==2*m)
printf("[%d,%d]\n",i,j);
}
printf("\n");
}
return 0;
}