hdoj 1238 Substrings

Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7652    Accepted Submission(s): 3441


Problem Description
You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.
 

Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings, followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string.
 

Output
There should be one line per test case containing the length of the largest string found.
 

Sample Input
  
  
2 3 ABCD BCDFF BRCD 2 rose orchid
 

Sample Output
  
  
2 2
 
暴力过!!!
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct record
{
    char s[110];
}num[1010];
bool cmp(record a,record b)
{
    return strlen(a.s)<strlen(b.s);
}
int main()
{
    int t,n;
    int i,j,l,m,k,h,len;
    int max,exist;
    char b[110],positive[110],invert[110];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s",num[i].s);
        }
        sort(num,num+n,cmp);
        strcpy(b,num[0].s);//用字符串b记录长度最短的字符串 
        l=strlen(b);max=0;
        for(i=0;i<l;i++)//子字符串开头 
        {
            for(j=i;j<l;j++)//子字符串结尾 
            {
                m=0;
                memset(positive,'\0',sizeof(positive));//初始化 
                memset(invert,'\0',sizeof(invert));
                for(k=i,h=j;k<=j,h>=i;k++,h--)
                {
                    positive[m]=b[k];//正序字符串 
                    invert[m]=b[h];//逆序字符串 
                    m++;
                } 
                len=strlen(invert);exist=1;
                for(k=1;k<n;k++)//遍历所有字符串 
                {
                    if(strstr(num[k].s,positive)==0&&strstr(num[k].s,invert)==0)
                    {
                        exist=0;
                        break;
                    } 
                }
                if(exist&&len>max)
                max=len;
            }
        }
        printf("%d\n",max); 
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值