poj 3262 Protecting the Flowers

Protecting the Flowers

Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 4803

 

Accepted: 1915

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroysDi (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cowi to its barn requires 2 ×Ti minutes (Ti to get there andTi to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N
Lines 2.. N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

Hint

FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86.
 
 
思路很好想,就是ac过程不是很顺利,超时一次,WA一次。。。坑死我了。 
一: 要用_int64或者long;二:计算总破坏数时两个for循环会超时。
 
这道题思路:若是我们要赶2头牛,谁先谁后?比如说第一头t[1] = 3,d[1]=3;第二头t[2] =4,d[2]=2。先赶第一头des1=t[1] * d[2]=6;先赶第二头des2= t[2] * d[1]=12。
由于des1<des2,所以我们要先赶第一头牛,因为这样破坏数最小。n头牛思路也是一样的,总之我们先用sort按照两头牛的排序方法对这n头牛进行排序,然后从头到尾计算总的破坏数即可。
 
ac代码:
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define max 100000+10
using namespace std;
struct record
{
    __int64 time;
    __int64 des;
}num[max];
bool cmp(record a,record b)
{
    return a.time*b.des<a.des*b.time;
}
int main()
{
    __int64 n,i,j;
    __int64 cost,sum;
    while(scanf("%I64d",&n)!=EOF)
    {
        sum=0;
        for(i=0;i<n;i++)
        {
            scanf("%I64d%I64d",&num[i].time,&num[i].des);
            sum+=num[i].des;//记录单位时间总破坏数 
        }
        cost=0;
        sort(num,num+n,cmp);
        for(i=0;i<n-1;i++)
        {
            sum-=num[i].des;//去掉赶走牛的破坏数 
            cost+=sum*2*num[i].time; 
        }
        printf("%I64d\n",cost);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值