zoj 3878 Convert QWERTY to Dvorak


Convert QWERTY to Dvorak


Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:

Qwerty Layout
The QWERTY Layout

Dvorak Layout
The Dvorak Layout

Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

Output

The Dvorak document.

Sample Input
Jgw Gqm Andpw a H.soav Patsfk f;doe
Nfk Gq.d slpt a X,dokt vdtnsaohe
Kjd yspps,glu pgld; aod yso kd;kgluZ
1234567890
`~!@#$%^&*()}"']_+-=ZQqWEwe{[\|
ANIHDYf.,bt/
ABCDEFuvwxyz
Sample Output

Hi, I'm Abel, a Dvorak Layout user.

But I've only a Qwerty keyboard.

The following lines are for testing:

1234567890

`~!@#$%^&*()+_-={}[]:"'<>,.?/\|

ABCDEFuvwxyz

AXJE>Ugk,qf;

 

一开始用字符串输入SF了,又来个没见过的错误,最后用字符输入才过。。。

 

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
#include<stack>
#include<algorithm>
using namespace std;
char s1[]={"_+QWERTYUIOP{}-=qwertyuiop[]ASDFGHJKL:\"asdfghjkl;'ZXCVBNM<>?zxcvbnm,./"};
char s2[]={"{}\"<>PYFGCRL?+[]',.pyfgcrl/=AOEUIDHTNS_aoeuidhtns-:QJKXBMWVZ;qjkxbmwvz"};
void solve(char op)
{
    int i;
    for(i=0;s1[i];i++)
    {
        if(s1[i]==op)
        {
            printf("%c",s2[i]);
            return ;
        }
    }
    printf("%c",op);
}
int main()
{
    char str[1010];
    char op;
    while(scanf("%c",&op)!=EOF)
    {
        solve(op);
    }
    return 0;
}


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值