zzuoj 10399: F.Turing equation

10399: F.Turing equation

时间限制: 1 Sec  内存限制: 128 MB
提交: 108  解决: 55
[ 提交][ 状态][ 讨论版]

题目描述

The fight goes on, whether to store  numbers starting with their most significant digit or their least  significant digit. Sometimes  this  is also called  the  "Endian War". The battleground  dates far back into the early days of computer  science. Joe Stoy,  in his (by the way excellent)  book  "Denotational Semantics", tells following story:
"The decision  which way round the digits run is,  of course, mathematically trivial. Indeed,  one early British computer  had numbers running from right to left (because the  spot on an oscilloscope tube  runs from left to right, but  in serial logic the least significant digits are dealt with first). Turing used to mystify audiences at public lectures when, quite by accident, he would slip into this mode even for decimal arithmetic, and write  things  like 73+42=16.  The next version of  the machine was  made  more conventional simply  by crossing the x-deflection wires:  this,  however, worried the engineers, whose waveforms  were all backwards. That problem was in turn solved by providing a little window so that the engineers (who tended to be behind the computer anyway) could view the oscilloscope screen from the back.

You will play the role of the audience and judge on the truth value of Turing's equations.

输入

The input contains several test cases. Each specifies on a single line a Turing equation. A Turing equation has the form "a+b=c", where a, b, c are numbers made up of the digits 0,...,9. Each number will consist of at most 7 digits. This includes possible leading or trailing zeros. The equation "0+0=0" will finish the input and has to be processed, too. The equations will not contain any spaces.

输出

For each test case generate a line containing the word "TRUE" or the word "FALSE", if the equation is true or false, respectively, in Turing's interpretation, i.e. the numbers being read backwards.

样例输入

73+42=16
5+8=13
0001000+000200=00030
0+0=0

样例输出

TRUE
FALSE
TRUE
注意并不只有0+0=0 就跳出,像000+000=000 也跳出。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<algorithm>
#define INF 0x3f3f3f
#define MAX 500+10
using namespace std;
int main()
{
    int k,i,j,l;
    char a[10],b[10],c[10];
    char str[50];
    int x,y,z;
    while(scanf("%s",str)!=EOF)
    {
        l=strlen(str);
        for(i=0,k=0;i<l;i++,k++)
        {
            if(str[i]=='+')
            {
                ++i;
                break;
            }
            a[k]=str[i];
        }
        a[k]='\0';
        for(k=0;i<l;i++,k++)
        {
            if(str[i]=='=')
            {
                ++i;
                break;
            }
            b[k]=str[i];
        }
        b[k]='\0';
        for(k=0;i<l;i++,k++)
        {
            c[k]=str[i];
        }
        c[k]='\0';
        x=0;
        for(i=strlen(a)-1;i>=0;i--)
        {
            x=x*10+a[i]-'0';
        }
        y=0;
        for(i=strlen(b)-1;i>=0;i--)
        {
            y=y*10+b[i]-'0';
        }
        z=0;
        for(i=strlen(c)-1;i>=0;i--)
        {
            z=z*10+c[i]-'0';
        }
        if(x==0&&y==0&&z==0)
        break;
        if(x+y==z)
        printf("TRUE\n");
        else 
        printf("FALSE\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值