hdoj 2899 Strange fuction 【二分查找 注意精度】



Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4285    Accepted Submission(s): 3090


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
 
题意不解释了吧。。。

思路:先求导数f(x) =  42* x^6 +48 * x ^ 5 + 21 *x^2+10 * x - y  (0 <= x <=100),由数学知识我们知道当f(x) 为0时,为极值(对于本题应该是最小值了)。 接下来求满足f(x) = 0时的x值,从区间[0, 100] 二分查找即可。

#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <string>
#include <cstdlib>
#include <cmath>
#include <algorithm>
using namespace std;
double work(double a)
{
	return 42 * pow(a, 6) + 48 * pow(a, 5) + 21 * pow(a, 2) + 10 * a;
}
double ans(double x, double y)
{
	return 6 * pow(x, 7) + 8 * pow(x, 6) + 7 * pow(x, 3) + 5 * pow(x, 2) - y * x; 
}
int main()
{
	int t;
	double left, right, mid;
	double y;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%lf", &y);
		left = 0, right = 100, mid = 50;
		while(fabs(work(mid) - y) > 0.000001)
		{
			if(work(mid) - y >= 0)//正值 mid过大 
			{
				right = mid;
				mid = (left + mid) / 2;
			} 
			else//负值 mid过小 
			{
				left = mid;
				mid = (mid + right) / 2;
			}
		}
		printf("%.4lf\n", ans(mid, y));
	} 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值