HDOJ 2899 Strange fuction(二分 || 三分)

Strange fuction



Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
题目大意:给出函数F(x) = 6 * x ^ 7 + 8 * x ^ 6 + 7 * x ^ 3 + 5 * x ^ 2 - y * x,求使得F(x)的最小值,其中x∈[0,100],0 < y < 1e10。

解题思路:由于给出的函数F(x)的单调性不确定,所以不能直接二分。对F(x)求导后,问题可以转化成求[0,100]内的x使得F'(x) = y,然后二分即可。或者直接对F(x)三分,求它的极值点。

代码如下:

//二分搜索代码
#include <cstdio>
#include <cmath>
#define EPS 1e-6
double y;

double F(double x)
{
	return 6 * pow(x,7.0) + 8 * pow(x,6.0) + 7 * pow(x,3.0) + 5 * pow(x,2.0) - y * x;
}

double derF(double x)
{
	return 42 * pow(x,6.0) + 48 * pow(x,5.0) + 21 * pow(x,2.0) + 10 * pow(x,1.0);
}

int main()
{
	int t;
	double lb,ub;
	scanf("%d",&t);
	while(t--){
		scanf("%lf",&y);
		lb = 0,ub = 100;
		while(ub - lb > EPS){
			double mid = (lb + ub) / 2;
			if(derF(mid) < y)
				lb = mid;
			else
				ub = mid;
		}
		printf("%.4lf\n",F(lb));
	}
	return 0;
}
//三分搜索代码
#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;

const double EPS = 1e-6;
double y;
double fun(double x)
{
	return 6 * pow(x,7.0) + 8 * pow(x,6.0) + 7 * pow(x,3.0) + 5 * pow(x,2.0) - y * x;
}

int main()
{
	double lb,ub,lm,um;
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%lf",&y);
		lb = 0,ub = 100.0;
		while(ub - lb > EPS){
			lm = (lb + ub) / 2.0;
			um = (lm + ub) / 2.0;
			if(fun(lm) > fun(um))
				lb = lm;
			else
				ub = um;
		}
		printf("%.4lf\n",fun(lb));
	}
	return 0;
 }



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值