hdoj 1757 A Simple Math Problem 【矩阵快速幂】



A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3528    Accepted Submission(s): 2133


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
      
      
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
      
      
45 104
 


AC这一题好爽! 一气呵成。


题意:当 x < 10时 f(x) = x.当x >= 10时 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);、

现在给你a0~a9,让你求出f(k) % m。


分析:矩阵快速幂主要是构造矩阵。给个图示就明白了

 


 目标矩阵                              原矩阵ori                             矩阵F

 

算法实现:

1,当k<=9时,直接输出;

2,当k >9时,先求原矩阵的(k-9)次幂res矩阵,在求幂的过程中对m取余。最后res矩阵再与矩阵F相乘得到矩阵ans,相乘的过程中对m取余。ans矩阵的第一个元素就是答案。


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 12
#define LL long long
using namespace std;
struct Matrix
{
    LL a[MAXN][MAXN];
    int r, c;
};
Matrix ori, res;
LL a[MAXN];
LL f[MAXN];
void init()
{
    //构造初始10*10矩阵
    memset(ori.a, 0, sizeof(ori.a));
    ori.r = ori.c = 10;// 10*10矩阵
    for(int i = 0; i < 10; i++)
        ori.a[0][i] = a[i];
    for(int i = 1; i < 10; i++)
        ori.a[i][i-1] = 1;
    //构造初始单位矩阵
    res.r = res.c = 10;
    memset(res.a, 0, sizeof(res.a));
    for(int i = 0; i < 10; i++)
        res.a[i][i] = 1;
}
Matrix muitl(Matrix x, Matrix y, int mod)
{
    Matrix z;
    memset(z.a, 0, sizeof(z.a));
    z.r = x.r; z.c = y.c;
    for(int i = 0; i < x.r; i++)
    {
        for(int k = 0; k < x.c; k++)
        {
            if(x.a[i][k] == 0) continue;
            for(int j = 0; j < y.c; j++)
                z.a[i][j] = (z.a[i][j] + (x.a[i][k] * y.a[k][j]) % mod) % mod;
        }
    }
    return z;
}
void Matrix(int n, int mod)
{
    while(n)
    {
        if(n & 1)
            res = muitl(ori, res, mod);
        ori = muitl(ori, ori, mod);
        n >>= 1;
    }
}
LL ans[MAXN];//结果矩阵
void solve(int n, int mod)
{
    Matrix(n, mod);//求10*10矩阵的n次幂对mod取余
    memset(ans, 0, sizeof(ans));
    for(int i = 0; i < 10; i++)
    {
        for(int k = 0; k < 10; k++)
        {
            if(res.a[i][k] == 0) continue;
            ans[i] = (ans[i] + (res.a[i][k] * f[k]) % mod) % mod;
        }
    }
    printf("%lld\n", ans[0]);
}
int main()
{
    int k, m;
    while(scanf("%d%d", &k, &m) != EOF)
    {
        for(int i = 0; i < 10; i++)
            scanf("%lld", &a[i]), f[i] = 9-i;
        if(k < 10)
        {
            printf("%d\n", k);
            continue;
        }
        init();//构造矩阵
        solve(k-9, m);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值