hdoj-1757-A Simple Math Problem【矩阵的快速幂】

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3465 Accepted Submission(s): 2087


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.

Output
For each case, output f(k) % m in one line.

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0

Sample Output
  
  
45 104

Author
linle

Source

Recommend
lcy | We have carefully selected several similar problems for you: 1575 1588 3117 2276 2256

#include<stdio.h> 
#include<string.h>
struct matrix{
	int m[10][10];
}ans,base;
int MOD;
matrix multi(matrix a,matrix b){
	matrix temp;
	for(int i=0;i<10;++i){
		for(int j=0;j<10;++j){
			temp.m[i][j]=0;
			for(int k=0;k<10;++k)
			  temp.m[i][j]=(temp.m[i][j]+a.m[i][k]*b.m[k][j])%MOD;
		}
	}
	return temp;
}
void output(matrix a){
	for(int i=0;i<10;++i){
		for(int j=0;j<10;++j)
		printf("%d ",a.m[i][j]);
		printf("\n");
	}
	printf("**************\n");
}
matrix fast_mod(int n) {//求base的 n 次方 
    //为base 赋初值
    memset(base.m,0,sizeof(base.m));
    for(int i=0;i<10;++i){
    	scanf("%d",&base.m[0][i]);
    }
    for(int i=1;i<10;++i)	base.m[i][i-1]=1;
	// 将 矩阵ans 初始化为单位矩阵 
    //output(base);
	memset(ans.m,0,sizeof(ans.m));
	for(int i=0;i<10;++i) ans.m[i][i]=1;
    //	output(ans);
	while(n){
		if(n & 1)  ans=multi(ans,base);
		
		base=multi(base,base);
		n>>=1;
	}
	return ans;
}
int main(){
	int k,m;
	while(~scanf("%d%d",&k,&m)){
		MOD=m;
		fast_mod(k-9);
		int i,j,ts=0;
		for(i=0,j=9;i<9;++i,--j){
			ts=(ts+ans.m[0][i]*j)%MOD;
		}
		printf("%d\n",ts);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值