poj 1753 Flip Game 【高斯消元 + 状压枚举自由变元】

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35432 Accepted: 15487

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4



题意同poj 1681。


思路:做两次高斯消元 + 枚举自由变元,维护最小值就可以了。



AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 20
#define INF 0x3f3f3f3f
using namespace std;
char str[4][4];
int a[MAXN][MAXN];
int free_rec[MAXN];
int x[MAXN];
int equ, var;
void init_a(int kind)
{
    equ = var = 16;
    memset(a, 0, sizeof(a));
    for(int i = 0; i < 4; i++)
    {
        for(int j = 0; j < 4; j++)
        {
            int num = i*4+j;
            if(str[i][j] == 'b')
                a[num][var] = kind ^ 1;
            else
                a[num][var] = kind ^ 0;
            a[num][num] = 1;
            if(i > 0) a[num][num-4] = 1;
            if(j > 0) a[num][num-1] = 1;
            if(i < 3) a[num][num+4] = 1;
            if(j < 3) a[num][num+1] = 1;
        }
    }
}

int Gauss()
{
    int max_r, k;
    int col = 0;
    int num = 0;
    for(k = 0; k < equ && col < var; k++, col++)
    {
        max_r = k;
        for(int i = k+1; i < equ; i++)
            if(a[i][col] > a[max_r][col])
                max_r = i;
        if(max_r != k)
            for(int i = col; i < var+1; i++)
                swap(a[k][i], a[max_r][i]);
        if(a[k][col] == 0)
        {
            k--;
            free_rec[num++] = col;
            continue;
        }
        for(int i = k+1; i < equ; i++)
            if(a[i][col] != 0)
                for(int j = col; j < var+1; j++)
                    a[i][j] ^= a[k][j];
    }
    for(int i = k+1; i < equ; i++)
        if(a[i][col] != 0)
            return -1;
    return var - k;
}
int solve(int S)
{
    int ans = INF;
    int state = (1<<S);
    for(int i = 0; i < state; i++)
    {
        int cnt = 0;
        for(int j = 0; j < S; j++)
        {
            if((1<<j) & i)
            {
                cnt++;
                x[free_rec[j]] = 1;
            }
            else
                x[free_rec[j]] = 0;
        }
        for(int j = var-S-1; j >= 0; j--)
        {
            int temp = a[j][var];
            for(int l = j+1; l < var; l++)
                if(a[j][l])
                    temp ^= x[l];
            x[j] = temp;
            cnt += x[j] ? 1 : 0;
        }
        ans = min(ans, cnt);
    }
    return ans;
}
int main()
{
    while(scanf("%s", str[0]) != EOF)
    {
        scanf("%s", str[1]);
        scanf("%s", str[2]);
        scanf("%s", str[3]);
        //1表示black 0表示white
        init_a(0);//结束状态为white
        int free_num = Gauss();
        int ans = INF;
        if(free_num != -1)
            ans = solve(free_num);
        init_a(1);//结束状态为black
        free_num = Gauss();
        if(free_num != -1)
            ans = min(ans, solve(free_num));
        if(ans == INF)
            printf("Impossible\n");
        else
            printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值