Maximum CliqueTime Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 3207 Accepted Submission(s): 1689
Problem Description
Given a graph G(V, E), a clique is a sub-graph g(v, e), so that for all vertex pairs v1, v2 in v, there exists an edge (v1, v2) in e. Maximum clique is the clique that has maximum number of vertex.
Input
Input contains multiple tests. For each test:
The first line has one integer n, the number of vertex. (1 < n <= 50) The following n lines has n 0 or 1 each, indicating whether an edge exists between i (line number) and j (column number). A test with n = 0 signals the end of input. This test should not be processed.
Output
One number for each test, the number of vertex in maximum clique.
Sample Input
Sample Output
|
题意:给定N个点的无向图,让你求最大团。
直接暴力的话 跑了9297ms,差点TLE
代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN (100+10)
using namespace std;
int Map[MAXN][MAXN];
bool used[MAXN];
int N;
int now, ans;
bool judge(int u)
{
for(int i = 1; i < u; i++)
if(used[i] && !Map[u][i])
return false;
return true;
}
bool flag;
void DFS(int u)
{
if(u > N)
{
ans = max(now, ans);
return ;
}
if(judge(u))
{
now++;
used[u] = true;
DFS(u+1);
now--;
}
if(now + N - u > ans)
{
used[u] = false;
DFS(u+1);
}
}
int main()
{
while(scanf("%d", &N), N)
{
for(int i = 1; i <= N; i++)
for(int j = 1; j <= N; j++)
scanf("%d", &Map[i][j]);
memset(used, false, sizeof(used));
now = ans = 0; flag = false;
DFS(1);
printf("%d\n", ans);
}
return 0;
}
优化后跑了1638ms
AC代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN (100+10)
using namespace std;
int N, M;
int Clique[MAXN];//Clique[i]记录(i-N)这些节点可以构成的最大团
int Map[MAXN][MAXN];
int New[MAXN][MAXN];
int ans;
int DFS(int T, int cnt)//DFS遍历层次 计数
{
if(T == 0)
{
if(ans < cnt)
{
ans = cnt;
return 1;
}
return 0;
}
for(int i = 0; i < T; i++)
{
if(T - i + cnt <= ans) return 0;
int u = New[cnt][i];
if(Clique[u] + cnt <= ans) return 0;
int num = 0;
for(int j = i+1; j < T; j++)
if(Map[u][New[cnt][j]])
New[cnt+1][num++] = New[cnt][j];
if(DFS(num, cnt+1)) return 1;
}
return 0;
}
int MaxClique()
{
memset(Clique, 0, sizeof(Clique));
ans = 0;
for(int i = N; i >= 1; i--)
{
int Size = 0;
for(int j = i+1; j <= N; j++)//根据后面的节点构建新图
if(Map[i][j])
New[1][Size++] = j;
DFS(Size, 1);
Clique[i] = ans;
}
return ans;
}
int main()
{
while(scanf("%d", &N), N)
{
for(int i = 1; i <= N; i++)
for(int j = 1; j <= N; j++)
scanf("%d", &Map[i][j]);
printf("%d\n", MaxClique());
}
return 0;
}