HDU1530:Maximum Clique(最大团)

42 篇文章 0 订阅

Maximum Clique

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4546    Accepted Submission(s): 2392


Problem Description
Given a graph G(V, E), a clique is a sub-graph g(v, e), so that for all vertex pairs v1, v2 in v, there exists an edge (v1, v2) in e. Maximum clique is the clique that has maximum number of vertex.
 

Input
Input contains multiple tests. For each test:

The first line has one integer n, the number of vertex. (1 < n <= 50)

The following n lines has n 0 or 1 each, indicating whether an edge exists between i (line number) and j (column number).

A test with n = 0 signals the end of input. This test should not be processed.
 

Output
One number for each test, the number of vertex in maximum clique.
 

Sample Input
  
  
5 0 1 1 0 1 1 0 1 1 1 1 1 0 1 1 0 1 1 0 1 1 1 1 1 0 0
 

Sample Output
  
  
4
 

Author
CHENG, Long
 

Source
题意:找出图的最大团,最大团即点数最多的完全图,完全图即两两点都有边相连。

思路:dfs。

稍微暴力版:

# include <iostream>
# include <cstdio>
# include <cstring>
using namespace std;
int m[53][53], n, vis[53], cnt, ans;
void dfs(int x)
{
    if(x > n)
    {
        ans = max(ans, cnt);
        return;
    }
    int flag = 1;
    for(int i=1; i<x; ++i)
    {
        if(vis[i] && !m[i][x])
        {
            flag = 0;
            break;
        }
    }
    if(flag)
    {
        vis[x] = 1, ++cnt;
        dfs(x+1);
        vis[x] = 0, --cnt;
    }
    if(n-x+cnt > ans) dfs(x+1);
}
int main()
{
    while(~scanf("%d",&n),n)
    {
        cnt = ans = 0;
        memset(vis, 0, sizeof(vis));
        for(int i=1; i<=n; ++i)
            for(int j=1; j<=n; ++j)
            scanf("%d",&m[i][j]);
        dfs(1);
        printf("%d\n",ans);
    }
    return 0;
}
dp版:

# include <iostream>
# include <cstdio>
# include <cstring>
using namespace std;
int m[53][53], n, ans, dp[53], a[53][53];//dp[i]表示在第i个数到后面可以选的最大团。
void dfs(int up, int dep)
{
    if(up == 0)
    {
        ans = max(ans, dep);
        return;
    }
    for(int i=0; i<up; ++i)
    {
        int cnt = 0;
        int u = a[dep][i];
        if(dep + n - u + 1 <= ans) return;
        if(dep + dp[u] <= ans) return;
        for(int j=i+1; j<up; ++j)
        {
            int v = a[dep][j];
            if(m[u][v]) a[dep+1][cnt++] = v;
        }
        dfs(cnt, dep+1);
    }
}
int clique()
{
    for(int i=n; i>0; --i)
    {
        int cnt = 0;
        for(int j=i+1; j<=n; ++j)
        {
            if(m[i][j]) a[1][cnt++] = j;
        }
        dfs(cnt, 1);
        dp[i] = ans;
    }
    return ans;
}
int main()
{
    while(~scanf("%d",&n),n)
    {
        ans = 0;
        memset(a, 0, sizeof(a));
        memset(dp, 0, sizeof(dp));
        for(int i=1; i<=n; ++i)
            for(int j=1; j<=n; ++j)
            scanf("%d",&m[i][j]);
        printf("%d\n",clique());
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值