TOYS
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 12509 | Accepted: 6053 |
Description
Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0 3 1 4 3 6 8 10 10 15 30 1 5 2 1 2 8 5 5 40 10 7 9 4 10 0 10 100 0 20 20 40 40 60 60 80 80 5 10 15 10 25 10 35 10 45 10 55 10 65 10 75 10 85 10 95 10 0
Sample Output
0: 2 1: 1 2: 1 3: 1 4: 0 5: 1 0: 2 1: 2 2: 2 3: 2 4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are "in" the box.
题意:给定一个矩形面,现在用n条从左向右有序线段将它分成n+1块,给出m个在矩形面里面的点,问每个块有多少个点在里面。
思路:二分查找每个点的位置,找到所属块的编号,统计下就好了。用向量的叉积判断点在线段的左边还是右边,二分压缩即可。
AC代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (5000+10)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
struct Point{
double x, y;
Point(){}
Point(double X, double Y){
x = X; y = Y;
}
};
Point P[MAXN];
Point operator - (Point A, Point B){
return Point(A.x-B.x, A.y-B.y);
}
Point operator + (Point A, Point B){
return Point(A.x+B.x, A.y+B.y);
}
double Cross(Point A, Point B){
return A.x*B.y - A.y*B.x;
}
struct Line{
Point s, e;
Line(){}
Line(Point S, Point E){
s = S, e = E;
}
};
Line L[MAXN];
int Find(int l, int r, Point A)
{
int id;
while(r >= l)
{
int mid = (l + r) >> 1;
if(Cross(A-L[mid].s, A-L[mid].e) < 0)
{
id = mid;
r = mid - 1;
}
else
l = mid + 1;
}
return id;
}
int ans[MAXN];
int main()
{
int n, m; double x1, y1, x2, y2;
while( Ri(n), n)
{
scanf("%d%lf%lf%lf%lf", &m, &x1, &y1, &x2, &y2);
for(int i = 0; i < n; i++)
{
Rf(L[i].s.x), Rf(L[i].e.x);
L[i].s.y = y1; L[i].e.y = y2;
}
CLR(ans, 0);
L[n] = Line(Point(x2, y1), Point(x2, y2));
for(int i = 0; i < m; i++)
{
Rf(P[i].x), Rf(P[i].y);
ans[Find(0, n, P[i])]++;
}
for(int i = 0; i <= n; i++)
printf("%d: %d\n", i, ans[i]);
printf("\n");
}
return 0;
}