poj 1651 Multiplication Puzzle 【区间dp】

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7926 Accepted: 4892

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650


题意:给你n个数num[],去掉第i个数(不能是第一个和最后一个)的代价 = num[i] * num[i-1] * num[i+1]。现在问你去掉中间n-2个数的最小代价。


思路:很基础的区间dp了。

枚举最后一个去掉的数。状态转移

dp[i][j] = min(dp[i][j], dp[i][k-1] + dp[k+1][j] + num[k] * num[i-1] * num[j+1]);


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f3f
#define eps 1e-8
#define MAXN (100+10)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
#define PI acos(-1.0)
using namespace std;
int dp[MAXN][MAXN], num[MAXN];
int main()
{
    int n;
    while(Ri(n) != EOF)
    {
        for(int i = 0; i < n; i++)
            Ri(num[i]);
        CLR(dp, INF);
        for(int i = n-2; i >= 1; i--)
        {
            for(int j = i; j < n-1; j++)
            {
                if(i == j)
                    dp[i][j] = num[i] * num[i-1] * num[i+1];
                else
                {
                    for(int k = i; k <= j; k++)
                    {
                        if(k == i)
                            dp[i][j] = min(dp[i][j], dp[k+1][j] + num[k] * num[j+1] * num[i-1]);
                        else if(k == j)
                            dp[i][j] = min(dp[i][j], dp[i][k-1] + num[k] * num[j+1] * num[i-1]);
                        else
                            dp[i][j] = min(dp[i][j], dp[i][k-1] + dp[k+1][j] + num[k] * num[i-1] * num[j+1]);
                    }
                }
            }
        }
        Pi(dp[1][n-2]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值