POJ2387--Til the Cows Come Home(dijkstra算法)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

T:给出T条数据    N:有N个点

点1到2的距离为20,以此类推,最后计算1到5的最短距离


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
using namespace std;
#define INF 1<<29

int map[1001][1001];
int T,N;


void dijk()
{
    int vis[1001];
    int dis[1001];//各顶点到1的距离
    int v,minN;
    for(int i = 1;i<=N;i++)
    {
        dis[i] = map[1][i];
        vis[i] = 0;
    }

    for(int i = 1;i<=N;i++)
    {
        minN = INF;
        for(int j=1;j<=N;j++)
            //记录最小值,和点
            if(!vis[j]&&dis[j]<minN)
            {
                v = j;
                minN = dis[j];

            }
        vis[v] = 1;
        
        for(int j =1;j<=N;j++)
        {
            //更新距离
            if(!vis[j]&&dis[j]>dis[v]+map[v][j])
            {
                dis[j] = dis[v]+map[v][j];
            }

        }

    }
    cout<<dis[N]<<endl;
}
int main()
{

    cin >> T >> N;
    //输入数据
    for(int i=1;i<=N;i++)
    {
      for(int j =1;j<=N;j++)
      {
          if(i == j) map[i][i] = 0;
          else map[i][j] = map[j][i]=INF;
      }
    }
    int a=0,b=0,c=0;
    //使用邻接矩阵,记录点与点之间的距离
    for(int i=1;i<=T;i++)
    {
       cin>>a>>b>>c;
       if(map[a][b]>c)
       {
           map[a][b] = c;
           map[b][a] = c;
       }
       //cout<<map[a][b];
    }


    dijk();
    
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值