HDU 3555 Bomb (数位dp)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 18031    Accepted Submission(s): 6632


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output

For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3554  3556  3557  3558  3559 
 


题目的意思是给你一个数,判断从1到这个数之间有子串49的数有多少个.

数据比较大,需要long long.

数位dp的入门题目


#include <iostream>
#include<string>
#include<cstring>
#include<set>
#include<cstdio>
using namespace std;
typedef long long ll;

ll dp[25][3];
ll a[25];

ll dfs(int pos,bool is,int state,bool limit)
{
    if(pos==-1&&state==1) return 1;
    else if(pos==-1) return 0;
    if(!limit&&dp[pos][state]!=-1) return dp[pos][state];
    int up=limit?a[pos]:9;
    ll temp=0;
    for(int i=0;i<=up;i++)
    {
        if((is&&i==9)||state==1)
        temp+=dfs(pos-1,i==4,1,limit&&a[pos]==i);
        else if(i==4) temp+=dfs(pos-1,i==4,2,limit&&a[pos]==i);
        else temp+=dfs(pos-1,i==4,0,limit&&a[pos]==i);
    }
    if(!limit) dp[pos][state]=temp;
    return temp;
}

ll solve(ll x)
{
    memset(dp,-1,sizeof(dp));
    int pos=0;
    while(x)
    {

        a[pos++]=x%10;
        x/=10;
    }
    return dfs(pos-1,0,0,true);
}

int main()
{
    ll x,y;
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        scanf("%lld",&x);
        cout<<solve(x)<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值