POJ 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14875 Accepted: 7471

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

这个题目问的是保证前缀和后缀相同的情况下,求解这个前缀或后缀的长度。

KMP的next值不就是该位前面的字符串中前缀后缀长度相同的位数么。

我们只需要从最后面第len(len为字符串长度)开始找,找到一个前缀和后缀长度后,跳到前缀的后一个,继续把前缀作为处理的字符串继续找。直到最后到0.代码如下:

/*************************************************************************
	> File Name: Seek_the_Name.cpp
	> Author: Zhanghaoran
	> Mail: chilumanxi@xiyoulinux.org
	> Created Time: Thu 26 Nov 2015 05:00:27 PM CST
 ************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;

void prekmp(char x[], int m, int nextKmp[]){
    int i, j;
    i = 0;
    j = nextKmp[0] = -1;
    while(i < m){
        if(j == -1 || x[i] == x[j])
            nextKmp[++ i] = ++ j;
        else 
            j = nextKmp[j];
    }
    //for(int i = 0; i <= m; i ++)
    //    cout << nextKmp[i] << " ";
    //cout << endl;
}

int nexti[1000010];
char a[1000010];
int temp[1000010];
int main(void){
    while(~scanf("%s", a)){
        int ans = 0;
        int len = strlen(a);
        prekmp(a, len, nexti);
        int p = len;
        temp[ans ++] = len;
        while(nexti[p]){
            p = nexti[p];
            temp[ans ++] = p;
        }
        for(int i = ans - 1; i >= 0; i --)
            cout << temp[i] << " ";
        cout << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值