LightOJ - 1038 Race to 1 Again (期望DP)

Race to 1 Again

 

Rimi learned a new thing about integers, which is - any positive integer greater than 1 can be divided by its divisors. So, he is now playing with this property. He selects a number N. And he calls this D.

In each turn he randomly chooses a divisor of D (1 to D). Then he divides D by the number to obtain new D. He repeats this procedure until D becomes 1. What is the expected number of moves required for N to become 1.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case begins with an integer N (1 ≤ N ≤ 10^5).

Output

For each case of input you have to print the case number and the expected value. Errors less than 10-6 will be ignored.

Sample Input

3

1

2

50

Sample Output

Case 1: 0

Case 2: 2.00

Case 3: 3.0333333333

题目链接:https://vjudge.net/problem/LightOJ-1038
题目大意:给一个数n,每次除一个它的因子成为一个新的数,反复此操作,一直到为1为止,问除法的次数的期望
思路:cnt是n的因子个数(包括1和n),n的操作次数的期望为:

Pn= 1/n* ( (Pa1+1) + (Pa2+1) +...... (Pacnt+1))
Pn==Pacnt,所以公式可以化简为:

Pn=( ( Pa1 + Pa2 + .......+Pacnt-1) + cnt ) / ( cnt -1 )

预处理出1-10^5所有数的期望

代码:

#include<bits/stdc++.h>
const int N=1e5;
double dp[N+5];
void init()
{
    dp[0]=dp[1]=0;
    dp[2]=2;
    for(int i=3;i<=N;i++)
    {
        dp[i]=0;
        int cnt=0;
        for(int j=1;j*j<=i;j++)
        {
            if(i%j) continue;
            cnt++;
            dp[i]+=dp[j];
            if(j*j==i) continue;
            cnt++;
            dp[i]+=dp[i/j];
        }
        dp[i]=(dp[i]+cnt)/(cnt-1);
    }
}
int main()
{
    init();
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("Case %d: %.6f\n",T++,dp[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值