Catch That Cow

                                Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.





题目大意:农民的牛跑了,农民现在在n处,牛在k处,现在农民可以前进1,或者后退1,也可以去到两倍的位置,花费的时间都为1分钟,问农民追上牛的最短时间。

这道题我开始是想着用dfs做的,后来发现用dfs太慢了。。。。

代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int n,k,vis[200005];
struct node
{
    int x,s;
}now,next;
int bfs(int n)
{
    queue<node>w;
    now.x=n,now.s=0;
    w.push(now);
    vis[n]=1;
    while(!w.empty())
    {
        now=w.front();
        w.pop();
        if(now.x==k) return now.s;
        for(int i=0;i<3;i++)
        {
            int xx;
            if(i==0) xx=now.x+1;
            if(i==1) xx=now.x-1;
            if(i==2) xx=now.x*2;
            if(xx>=0&&xx<200001&&!vis[xx])
            {
                vis[xx]=1;
                next.x=xx,next.s=now.s+1;
                w.push(next);
            }
        }
    }
    return -1;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(vis,0,sizeof(vis)); 
       if(n>=k)   //如果农民在牛前面就只能退
            printf("%d\n",n-k);
       else
        printf("%d\n",bfs(n));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值