HDU - 3038 How Many Answers Are Wrong (带权并查集)

How Many Answers Are Wrong

题目链接:https://vjudge.net/problem/HDU-3038

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

 

题目大意:

给出n,m,下面m行每一行有三个数,a,b,v,v代表的是区间  [ a,b ] 的和,如果后面与前面矛盾认为是假话,问多少句假话

思路:因为(a ,b] +(b,c] = (a,c] 的性质方便我们计算,所以可以把区间 [a,b] 转变成 (a -1,b] 的形式
输入 a b s   如果 a 的祖先和 b的祖先 相同就判断 v[b] -v[a] 是否等于s ,即 a 到祖先的距离 与 b 到祖先的距离的差 是否等于 a b 间的距离 ,如果不相等则说明这句是假话。  如果a 与 b 的祖先不同: f[fb]=fa;   v[fb]=v[a]+s-v[b];

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=200005;
int f[N],v[N];
int find(int x)
{
    if(f[x]==x) return x;
    else
    {
        int fa=f[x];
        f[x]=find(f[x]);
        v[x]+=v[fa];
        return f[x];
    }
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<=n;i++)
        {
            f[i]=i;
            v[i]=0;
        }
        int ans=0;
        for(int i=0;i<m;i++)
        {
            int a,b,s;
            scanf("%d%d%d",&a,&b,&s);
            a-=1;
            int fa=find(a),fb=find(b);
            if(fa!=fb)
            {
                f[fb]=fa;
                v[fb]=v[a]+s-v[b];
            }
            else if(v[b]-v[a]!=s) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值