LightOJ - 1188 Fast Queries (莫队)

Fast Queries

 

Given an array of N integers indexed from 1 to N, and q queries, each in the form i j, you have to find the number of distinct integers from index i to j (inclusive).

Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

The first line of a case is a blank line. The next line contains two integers N (1 ≤ N ≤ 105)q (1 ≤ q ≤ 50000). The next line contains N space separated integers forming the array. There integers range in [0, 105].

Each of the next q lines will contain a query which is in the form i j (1 ≤ i ≤ j ≤ N).

Output

For each test case, print the case number in a single line. Then for each query you have to print a line containing number of distinct integers from index i to j.

Sample Input

1

 

8 5

1 1 1 2 3 5 1 2

1 8

2 3

3 6

4 5

4 8

Sample Output

Case 1:

4

1

4

2

4

Note

Dataset is huge. Use faster I/O methods.

 

题目链接:https://vjudge.net/problem/LightOJ-1188

题目大意:有一个长度为n的数列,有m次查询,每次查询给出 l ,r 问在区间[l ,r]内有多少个不同的数字

思路:莫队模板题

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
const int N=100005;
int a[N],ans,c[N],b[N];
struct node
{
    int l,r,id,pos;
}q[N];
bool cmp(node a,node b)
{
    if(a.pos==b.pos) return a.r<b.r;
    return a.pos<b.pos;
}
void update(int x,int p)
{
    if(x==0) return;
    if(c[a[x]]) ans-=1;
    c[a[x]]+=p;
    if(c[a[x]]) ans+=1;
}
int main()
{
    int t,T=1;
    scanf("%d",&t);
    while(t--)
    {
        memset(c,0,sizeof(c));
        int n,m;
        scanf("%d%d",&n,&m);
        int p=sqrt(n);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&q[i].l,&q[i].r);
            q[i].id=i;
            q[i].pos=q[i].l/p;
        }
        sort(q,q+m,cmp);
        int l=0,r=0;
        ans=0;
        for(int i=0;i<m;i++)
        {
            while(l<q[i].l) update(l++,-1);
            while(l>q[i].l) update(--l,1);
            while(r>q[i].r) update(r--,-1);
            while(r<q[i].r) update(++r,1);
            b[q[i].id]=ans;
        }
        printf("Case %d:\n",T++);
        for(int i=0;i<m;i++)
            printf("%d\n",b[i]);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值