hdu2119二分图匹配

Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the '1' in this row or this column .

Your task is to give out the minimum times of deleting all the '1' in the matrix.
 
Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.
 
Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the '1' in the matrix.
 
Sample Input
  
  
3 3 0 0 0 1 0 1 0 1 0 0
 

Sample Output
  
  
2
删除所有的1,每次只能删除一横行,或是一竖行。
建图,明显二分图最大匹配;
#include<stdio.h>
#include<string.h>
#define maxn 102
int map[maxn][maxn],use[maxn],path[maxn];
bool dfs(int x,int m)
{
    for(int i=1;i<=m;i++)
    {
        if(use[i]||map[x][i]==0)
          continue ;
        use[i]=1;
        if(!path[i]||dfs(path[i],m))
        {
            path[i]=x;
            return true ;
        }
    }
    return false ;
}
void match(int n,int m)
{
    int sum=0;
    memset(path,0,sizeof(path));
    for(int i=1;i<=n;i++)
    {
        memset(use,0,sizeof(use));
        if(dfs(i,m)) sum++;
    }
    printf("%d\n",sum);
}
int main()
{
    int i,n,m,a,j;
    while(scanf("%d",&n)&&n)
    {
        scanf("%d",&m);
        memset(map,0,sizeof(map));
        for(i=1;i<=n;i++)
        for(j=1;j<=m;j++)
        {
            scanf("%d",&a);
            if(a==1)
              map[i][j]=1;
        }
        match(n,m);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值