poj_3295 Tautology(构造+枚举)

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12166 Accepted: 4645

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not
 
题目中只有5个变量,所以一共只要枚举2^5种情况,用一个堆栈去维护。
 
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <stack>
#include <bitset>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <algorithm>
#define FOP freopen("data.txt","r",stdin)
#define inf 0x3f3f3f3f
#define maxn 1000010
#define mod 1000000007
#define PI acos(-1.0)
#define LL long long
using namespace std;

char a[110];
stack<int> mS;
int p, q, r, s, t;

int solve()
{
    int len = strlen(a);
    int w, x;
    for(int i = len - 1; i >= 0; i--)
    {
        switch(a[i])
        {
        case 'p':
            mS.push(p);
            break;
        case 'q':
            mS.push(q);
            break;
        case 'r':
            mS.push(r);
            break;
        case 's':
            mS.push(s);
            break;
        case 't':
            mS.push(t);
            break;
        case 'K':
            w = mS.top();
            mS.pop();
            x = mS.top();
            mS.pop();
            mS.push(w && x);
            break;

        case 'A':
            w = mS.top();
            mS.pop();
            x = mS.top();
            mS.pop();
            mS.push(w || x);
            break;

        case 'N':
            w = mS.top();
            mS.pop();
            mS.push(!w);
            break;
        case 'C':
            w = mS.top();
            mS.pop();
            x = mS.top();
            mS.pop();
            mS.push(!w || x);
            break;

        case 'E':
            w = mS.top();
            mS.pop();
            x = mS.top();
            mS.pop();
            mS.push((!w || x)&&(!x || w));
            break;
        }
    }
    int res = mS.top();
    mS.pop();
    return res;

}

bool loop()
{
    for(p = 0; p < 2; p++)
        for(q = 0; q < 2; q++)
            for(r = 0; r < 2; r++)
                for(s = 0; s < 2; s++)
                    for(t = 0; t < 2; t++)
                    {
                        if(!solve()) return false;
                    }
    return true;
}

int main()
{
    while(~scanf("%s", a))
    {
        if(a[0] == '0') break;
        if(loop()) printf("tautology\n");
        else printf("not\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值