R - Milking Time——POJ C语言实现


R - Milking Time
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: NM, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43




C语言实现,先对时间段进行排序,然后DP代表前N段的最大值

#include<stdio.h>
#include<string.h>
int my_max(int x,int y)   {return x>y?x:y;}
typedef struct node{
	int star;
	int end;
	int eff;
}NODE;  
NODE que[1005];
int dp[1005];
int main()
{
	int n,m,r,i,j,max;
	NODE t;
	while(scanf("%d %d %d",&n,&m,&r)!=EOF)
	{
		memset(que,0,sizeof(que));
		memset(dp,0,sizeof(dp));
		for(i=0;i<m;i++)  scanf("%d %d %d",&que[i].star,&que[i].end,&que[i].eff);
		for(i=0;i<m;i++)
		{
			for(j=i;j<m;j++)
			{
				if(que[i].star>que[j].star)
				{
					t=que[j];
					que[j]=que[i];
					que[i]=t;
				}
			}
		}
		
		for(i=0;i<m;i++)
		{
			max=0;
			for(j=0;j<i;j++)
			{
				if(que[i].star-que[j].end>=r)
				{
					max=my_max(max,dp[j]);
				}
			} 
			dp[i]=max+que[i].eff;
		}
		max=0; 
		
		for(j=0;j<m;j++)//求出最大值 
			if(max<dp[j])
				max=dp[j]; 
        
		printf("%d\n",max); 
	}
	return 0;
}  



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=10005;
struct node
{
    int l,r,data;
    bool operator<(const node& tmp) const{
        if(l!=tmp.l)
            return l<tmp.l;//如果区间开始不一样,则按开始为标准比较 
        else
            return r<tmp.r;//如果区间开始一样,则按结束为标准比较 
    }
}p[maxn];

int dp[maxn];//表示选择到第M个区间 能获得的最大值

int main()
{
    int n,m,r;
    while(~scanf("%d%d%d",&n,&m,&r))
	{
        for(int i=0;i<m;i++)
		{
            scanf("%d%d%d",&p[i].l,&p[i].r,&p[i].data);
            dp[i]=0;//初始化DP 
        }
        sort(p,p+m);//排序 
        int j;
        for(int i=0;i<m;i++)
		{
            int maxx=0;
            for(j=0;j<i;j++)
				if(p[i].l-p[j].r>=r)//有一段r的距离 
				{
           		    maxx=max(maxx,dp[j]);//找到这个区间前面的最大值
           		}
            dp[i]=maxx+p[i].data;
        }
        int max=0;
        for(j=0;j<m;j++)//求出最大值 
			if(max<dp[j])
				max=dp[j]; 
        printf("%d\n",max);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值