Description
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.
Input
* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
Output
* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43
一群牛,每个牛有固定的挤奶时间,产量也固定,挤奶结束后r小时不能挤奶,问这个时间内最多挤多少奶。
对时间排序,按开始和结束随意(没找到反例),n^2算法,枚举i,每次向后更新值即可。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int dp[1005];
struct Node
{
int l,r,v;
}node[1005];
bool cmp(Node a,Node b)
{
if(a.l == b.l)return a.r < b.r;
return a.l < b.l;
}
int main()
{
#ifdef LOCAL
freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
//freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
#endif // LOCAL
int n,m,r;
scanf("%d%d%d",&n,&m,&r);
for(int i = 1;i <= m;i++)
scanf("%d%d%d",&node[i].l,&node[i].r,&node[i].v);
sort(node + 1,node + 1 + m,cmp);
memset(dp,0,sizeof(dp));
int ans = 0;
for(int i = 1;i <= m;i++)
{
dp[i] = max(dp[i],node[i].v);
for(int j = i + 1;j <= m;j++)
{
if(node[j].l >= node[i].r + r)
dp[j] = max(dp[j],dp[i] + node[j].v);
}
ans = max(ans,dp[i]);
}
printf("%d\n",ans);
return 0;
}