POJ 1988 Cube Stacking 并查集

Cube Stacking
Time Limit: 2000MS
Memory Limit: 30000K
Total Submissions: 16688
Accepted: 5724
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

这道也是并查集,但是需要点技巧,除了parent数组,还要开设 under数组,under[i]表示第i个方块下面有多少个方块。 under数组在堆合并和路径压缩的时候都要更新。 





这是从别处复制过来的讲解。

下面是我写的代码:

#include <iostream>
#include <cstdio>
#include <fstream>
#include <cstring>
using namespace std;

const int maxn = 30010;
int parent[maxn],under[maxn];

int find(int t)
{
    if(parent[t]<0)
        return t;
    int s=find(parent[t]);
    under[t]+=under[parent[t]];
    parent[t]=s;
    return s;
}
void merge(int l,int r)
{
    int u = find(l);
    int d = find(r);
    if(u==d)
        return;
    under[u]=-parent[d];
    parent[d]+=parent[u];//将子集成员个数加起来
    parent[u]=d;
}
int main()
{
    freopen("in.txt","r",stdin);
    int p,l,r,t;
    char c,str[10];
    memset(parent,-1,sizeof(parent));
    scanf("%d",&p);
    while(p--)
    {
        //getchar();
        scanf("%s",str);
        if(str[0]=='M')
        {
            scanf("%d%d",&l,&r);
            merge(l,r);
        }
        if(str[0]=='C')
        {
            scanf("%d",&t);
            find(t);//输出前必须更新一下under数组
            printf("%d\n", under[t]);
        }
    }

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值