缺陷键盘

Sample Input:
They are students.
aeiou
Sample Output:

Thy r stdnts.

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int main() {
	//string str1... 因string类只能使用cin输入,无法应对题目个性化输入,所以不常用
	char str1[100], str2[100];
	gets(str1);
	gets(str2);
	for(int i=0; i<strlen(str1); i++) {
		int flag = 0;
		for(int j=0; j<strlen(str2); j++)
			if(str1[i] == str2[j]) {
				flag = 1;
				break;
			}
		if(flag == 0) printf("%c",str1[i]);
	}
	return 0;
}

使用散列优化如下:

#include <cstdio>
#include <cstring>
using namespace std;
int main() {
	bool HashTable[10010];
	char a[100], b[100];
	gets(a);
	gets(b);
	for(int i=0; i<strlen(b); i++)
		HashTable[b[i]] = true;  //下标为ASCII码
	for(int i=0; i<strlen(a); i++)
		if(HashTable[a[i]] == false)
			printf("%c",a[i]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值