Hdu2717 Catch That Cow (BFS)

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12092    Accepted Submission(s): 3771


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 


 

Input
Line 1: Two space-separated integers: N and K
 


 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 


 

Sample Input
  
  
5 17
 


 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

 

题目大意:由给出的n点用最小的步数抵达k点,共有三种走法,左走一步右走一步,或者位置*2。

 

题解:用bfs每个方法走一次,第一次到达k点的步数一共最小。

 

#include<iostream>
#include<queue>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
struct node
{
    int x,step;
};
node st,ne,q;
bool vis[1000000];
int cnt;
int n,k;
void bfs();
int main(void)
{
    while(cin>>n>>k)
    {
        cnt=0;
        memset(vis,0,sizeof(vis));
        st.x=n;
        st.step=0;

        bfs();

        cout<<cnt<<endl;
    }
    return 0;
}
void bfs()
{
    queue<node> que;
    que.push(st);
    vis[n]=true;
    while(!que.empty())
    {
        q=que.front();
        que.pop();

        if(q.x==k)
        {
            cnt=q.step;
            return ;
        }

        ne.step=q.step+1;
        ne.x=q.x+1;
        if(ne.x>=0 &&ne.x<=k &&!vis[ne.x])
        {
            vis[ne.x]=true;
            que.push(ne);
           // cout<<ne.x<<endl<<"--------------"<<ne.step<<endl;
        }

        ne.x=q.x-1;
        if(ne.x>=0 && ne.x<=100000 &&!vis[ne.x])
        {
            vis[ne.x]=true;
            que.push(ne);
            //cout<<ne.x<<endl<<"--------------"<<ne.step<<endl;
        }
        ne.x=q.x*2;
        if(ne.x>=0 && ne.x<=100000 &&!vis[ne.x])
        {
            vis[ne.x]=true;
            que.push(ne);
            //cout<<ne.x<<endl<<"--------------"<<ne.step<<endl;
        }

    }
}


 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值