poj2405 Power Strings KMP

Power Strings

 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路:

KMP预处理nxt数组存前面的最长前后缀,对于整个字符串来说,如果len % (len - nxt[len - 1]) == 0,那么这个字符串肯定是有周期的并且周期T = len / (len - nxt[len - 1]),于是我们只需要暴力遍历一遍整个字符串就行了;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = (int)1e6 + 10;
char s[maxn];
int nxt[maxn];
void init(int n)
{
	memset(nxt,0,sizeof(nxt));
	nxt[0] = 0;
	int i = 1,j = 0;
	while (i < n)
	{
		if (s[i] == s[j])
			nxt[i ++] = ++ j;
		else if (!j)
			i ++;
		else
			j = nxt[j - 1];
	}
}
int main()
{
	while (~scanf("%s",s))
	{
		if (!strcmp(s,"."))
			break;
		int len = strlen(s);
		init(len);
		if (len % (len - nxt[len - 1]) == 0)
			printf("%d\n",len / (len - nxt[len - 1]));
		else
			printf("1\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值