openjudge heavy transportation

52 篇文章 1 订阅
34 篇文章 0 订阅

799:Heavy Transportation

总时间限制: 
3000ms 
内存限制: 
65536kB
描述
Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
输入
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
输出
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
样例输入
1
3 3
1 2 3
1 3 4
2 3 5
样例输出
Scenario #1:
4
来源

TUD Programming Contest 2004, Darmstadt, Germany


题目大意:有N个点,M条路,每条路有一个最大载重量,要通过这条路,载重量要不超过该路的最大载重量。某某某要从点1到点N,求所有路径中载重量最大的那条路径。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,f[1100],t,num,road,ans[21000],ans1,vis[1100];
struct data
{
int x,y,len;
};
data street[1000003];
bool pd;
int i,j,k,next[21000],point[1100],u[21000],v[21000],w[21000];
int cmp(data a,data b)
{
return a.len>b.len;
}
int find(int x)
{
if (f[x]==x)  return x;
f[x]=find(f[x]);
return f[x];
}
void chuli(int a,int b,int c)
{
road++; u[road]=a; v[road]=b; w[road]=c; next[road]=point[a]; point[a]=road;
    road++; u[road]=b; v[road]=a; w[road]=c; next[road]=point[b]; point[b]=road;
}
void dfs(int x)
{
if (x==n)
{
  pd=true;
  return;
     }
int mp=point[x];
while (mp!=0)
{
 if (vis[v[mp]]==0)
  {
ans1++;
vis[v[mp]]=1;
ans[ans1]=w[mp];
dfs(v[mp]);
if (pd==true) return;
ans1--;
  }
 mp=next[mp];
     }
}
int cmp1(int a,int b)
{
return a<b;
}
int main()
{
scanf("%d",&t);
for (k=1;k<=t;k++)
{
scanf("%d%d",&n,&m);
for (i=1;i<=n;i++)
f[i]=i;
for (i=1;i<=m;i++)
scanf("%d%d%d",&street[i].x,&street[i].y,&street[i].len);
sort(street+1,street+m+1,cmp);
num=0; road=0;
memset(point,0,sizeof(point));  memset(next,0,sizeof(next));
memset(w,0,sizeof(w)); memset(u,0,sizeof(u)); memset(v,0,sizeof(v));
for (i=1;i<=m;i++)
{
if (find(street[i].x)!=find(street[i].y))
{
int r1=find(street[i].x); int r2=find(street[i].y);
f[r2]=r1;
num++;
chuli(street[i].x,street[i].y,street[i].len);
}
if (num==n-1)
 break;
}
memset(ans,0,sizeof(ans)); memset(vis,0,sizeof(vis));
pd=false; ans1=0;
vis[1]=1;
dfs(1);
sort(ans+1,ans+ans1+1,cmp1);
printf("Scenario #%d:\n",k);
printf("%d\n",ans[1]);
printf("\n");
}
}//这道题我采用了最小生成树的兄弟最大生成树,按同样的方法建树,只不过是每次选取最大的边,建树后从1到N的路径是唯一的,所以只需遍历一遍这条路径找出路径中的最小值即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据引用中的背景信息,Hugo Heavy需要一个聪明的人告诉他从他的客户建造的巨型钢铁起重机所在的地方到达需要的地方是否存在一条街道能够承载这个重量。而根据引用中的信息,问题是要找到从交叉点1(Hugo的地方)到交叉点n(客户的地方)的最大运输重量。根据引用中的论文,一个新颖的非线性六自由度运输飞机模型在货物提取中被开发和验证。因此,根据这些信息,问题是要找到从交叉点1到交叉点n的最大允许重量,以便Hugo可以运输给客户。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [Heavy Transportation](https://blog.csdn.net/weixin_43850736/article/details/98874181)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* [Dynamics modeling and control of large transport aircraft in heavy cargo extraction (2011年)](https://download.csdn.net/download/weixin_38653664/19644813)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值