最短路变形 :Heavy Transportation

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo’s place) to crossing n (the customer’s place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

比如1到n的路径有3种,第一种到n的每个边的权是2, 4 ,5.
第二种是3, 4, 3。第三种是 4, 6, 1. 每个路径里权值最大的是5, 4, 6。
求这些的最小值, 5, 4, 6的最小值是4.

我用spfa写的,注意dis数组存的就是答案,不是到每个点的距离。
#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<algorithm>
#define inf 0x3f3f3f
using namespace std;
int m, n, tot;
int ne[1111111], dis[1111], vis[1111];
struct node
{
    int u, v, w, next;
} p[1111111];
void spfa(int x);
int main()
{
    int T;
    int l = 1;
    cin >> T;
    while(T--)
    {
    cin >> n >> m;
    tot = 0;
    memset(p, 0, sizeof(p));
    memset(ne, 0, sizeof(ne));
    memset(vis, 0, sizeof(vis));
    memset(dis, 0, sizeof(dis));      
    for(int i = 1; i <= m; i++)
    {
        int u, v, w;
        scanf("%d%d%d",&u,&v,&w);
        p[++tot] = (node)
        {
            u, v, w, ne[u]
        };
        ne[u] = tot;
        p[++tot] = (node)
        {
            v, u, w, ne[v]
        };
        ne[v] = tot;
    }
    spfa(1);
    printf("Scenario #%d:\n%d\n\n",l++, dis[n]);
    }
    return 0;
}

void spfa(int x)
{
    vis[x] = 1;
    dis[x] = inf;          ××××××××到它本身为inf××××××××
    queue<int> q;
    q.push(x);
    while(q.size())
    {
        int now = q.front();
        q.pop();
        vis[now] = 0;
        for(int i = ne[now]; i > 0; i = p[i].next)
        {
                if(dis[p[i].v] < min(dis[p[i].u], p[i].w))
                {
                    dis[p[i].v] = min(dis[p[i].u], p[i].w);    判断条件,画个图想想。
                    if(!vis[p[i].v])
                    {
                    vis[p[i].v] = 1;
                    q.push(p[i].v);
                    }
                }
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值