Avoid The Lakes

47 篇文章 1 订阅
Avoid The Lakes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6885 Accepted: 3669

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ KN × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: N, M, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4
C语言程序代码
/*
题意::
  给你N,M,F,分别表示地的长、宽、以及坐标点的个数
  接下来是F个点的坐标。找出连接在一块的坐标最大的个数。 
*/
#include<stdio.h>
#include<string.h>
int a[110][110];
int n,m,cnt;
void dfs(int x,int y)
{
 if(x<1||x>n||y<1||y>m)
  return ;
 if(a[x][y]==0)
  return ;
  cnt++;    
  a[x][y]=0;  
  dfs(x+1,y);
  dfs(x-1,y);
  dfs(x,y+1);
  dfs(x,y-1); 
} 
int main(){
 int x,y,i,j,t;
 scanf("%d%d%d",&n,&m,&t);//这块只用输入一次,如循环输入会超时,这块错了好几次 
 memset(a,0,sizeof(a));
 for(i=0;i<t;i++)
 {
  scanf("%d%d",&x,&y);
  a[x][y]=1;
 }
 int max=1;
 for(i=1;i<=n;i++)
 {
  for(j=1;j<=m;j++)
  {
   if(a[i][j]==1)
   {
    cnt=0;
    dfs(i,j);     
   }
   if(cnt>max)
    max=cnt;
  }
 }
 printf("%d\n",max);
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值