hdu 1907 John

John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3906    Accepted Submission(s): 2212


Problem Description
Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input
The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:
1 <= T <= 474,
1 <= N <= 47,
1 <= Ai <= 4747

 

Output
Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input
  
  
2 3 3 5 1 1 1
 

Sample Output
  
  
John Brother
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1913  1908  1914  1915  1909 

anti-nim游戏

 

         如果定义拿最后一个棋子的人输就成了anti-nim游戏。

         传说中的SJ定理登场了。实际上很多定理都会披上这么牛叉的名字。

         我们就一种情况一种情况的玩吧。

         这里的SG应该还是指的NIM中的SG

 

先手必胜有两种状态:

1.如果每一个小游戏都只剩下一个石子了,SG0

2.至少一堆石子>1,SG不为0.

 

证明

         1显然成立。

         2的话分两种情况

a.       只有一堆石子>1,好吧!整个生杀大权都交你主宰了。你可以把它变成1

b.       至少两队石子>1,你只需要把SG值边为0就可以了,这个操作之后,至少还有两堆石子>1,然后对方随便怎么操作,都会把SG变成非0,你们就一直这么玩就行了。

还需要证明1,2的反面是必败的。

1显然了。

2的话,你会把SG变成非0,而且因为现在至少两堆石子>1了,所以你还会给人家至少留一个>1的,那么无论怎么搞,都会送给后手一个必胜态。




#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,i,j,x,ans;
int main()
{
	scanf("%d",&n);
	for (i=1;i<=n;i++)
	 {
	 	 scanf("%d",&m);
	 	 int pd=0; ans=0; 
	 	 for (j=1;j<=m;j++)
	 	  {
	 	  	 scanf("%d",&x); ans^=x;
	 	  	 if (x>1) pd=1;
	 	  }
	 	if (ans==0&&pd==0) printf("John\n");
	 	else
		if (ans!=0&&pd==1) printf("John\n");
		else printf("Brother\n"); 
	 }
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值