hdu 2588 GCD

26 篇文章 0 订阅

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1461    Accepted Submission(s): 690


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1695  3501  2824  2582  1286 

题解:  sigma(i=1...n)  [gcd(i,n)>=m]

           = sigma(i=1...n)sigma(j=m...n) [gcd(i,n)==j]

           =sigma(i=1...n) sigma(j=m...n) [gcd(i/j,n/j)==1]

           设 i=i'*j

           =sigma(j=m..n) sigma(i'=1.. n/j) [gcd(i',n/j)==1]

           =sigma(j=m...n) phi(n/j)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
long long  m,n,ans;
int t;
long long phi(long long k)
{
 long long sum=k;
 for (long long i=2;i*i<=k;i++)
 if (k%i==0)
 {
  sum=sum*(i-1)/i;
  while (k%i==0)
   k/=i;
 }
 if (k>1)  sum=sum*(k-1)/k;
 return sum;
}
int main()
{
 scanf("%d",&t);
 for (int i=1;i<=t;i++)
 {
  scanf("%I64d%I64d",&n,&m);
  ans=0;
  for (int i=1;i*i<=n;i++)
  if (n%i==0)
   {
   	if (n/i==i&&i>=m)
   	 { ans+=phi(n/i); continue;}
   	if (i>=m)
   	 ans+=phi(n/i);
   	if (n/i>=m)
   	 ans+=phi(i);
   }
  printf("%I64d\n",ans);
 }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值