bzoj 3239: Discrete Logging (BSGS)

7 篇文章 0 订阅

3239: Discrete Logging

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 508   Solved: 324
[ Submit][ Status][ Discuss]

Description

Given a prime P, 2 <= P < 231, an integer B, 2 <= B < P, and an integer N, 2 <= N < P, compute the discrete logarithm of N, base B, modulo P. That is, find an integer L such that

    BL == N (mod P)

Input

Read several lines of input, each containing P,B,N separated by a space, 

Output

for each line print the logarithm on a separate line. If there are several, print the smallest; if there is none, print "no solution".

The solution to this problem requires a well known result in number theory that is probably expected of you for Putnam but not ACM competitions. It is Fermat's theorem that states

   B(P-1) == 1 (mod P)

for any prime P and some other (fairly rare) numbers known as base-B pseudoprimes. A rarer subset of the base-B pseudoprimes, known as Carmichael numbers, are pseudoprimes for every base between 2 and P-1. A corollary to Fermat's theorem is that for any m

   B(-m) == B(P-1-m) (mod P) .

Sample Input

5 2 1
5 2 2
5 2 3
5 2 4
5 3 1
5 3 2
5 3 3
5 3 4
5 4 1
5 4 2
5 4 3
5 4 4
12345701 2 1111111
1111111121 65537 1111111111

Sample Output

0
1
3
2
0
3
1
2
0
no solution
no solution
1
9584351
462803587

HINT

Source

[ Submit][ Status][ Discuss]


题解:BSGS

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<map>
#define LL long long 
using namespace std;
LL a,b,c;
map<LL,int> mp;
LL quickpow(int x)
{
	LL base=a%c; LL ans=1;
	while (x) {
		if (x&1) ans=ans*base%c;
		x>>=1;
		base=base*base%c;
	}
	return ans;
}
int main()
{
	freopen("a.in","r",stdin);
	while (scanf("%I64d%I64d%I64d",&c,&a,&b)!=EOF) {
		mp.clear();
		if (a%c==0) {
			printf("no solution\n");
			continue;
		}
		int p=false;
		int m=ceil(sqrt(c));
		LL ans;
		for (int i=0;i<=m;i++) {
			if (i==0) {
				ans=b%c; mp[ans]=i; continue;
			}
			ans=(ans*a)%c; mp[ans]=i;
		}
		LL t=quickpow(m); ans=1; bool pd=false;
		for (int i=1;i<=m;i++) {
			ans=ans*t%c;
			if (mp[ans]) {
				int t=i*m-mp[ans];
				printf("%d\n",(t%c+c)%c);
				pd=true;
				break;
			}
		}
		if (!pd) printf("no solution\n");
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值