UPC 1053 Mysterious Treasure (记忆化搜索)

这个题开始没想到全边的测试数据,不用记忆化搜索会 50个点800条边会搜索2*10^7次,然后改成记忆化搜索,暴力删边,昨天有点乱,结束了立马想到暴力删边哪里没解决,生气

Description

WNJXYK and DIDIDI is playing a game. DIDIDI draws a directed graph G on the paper which contains n points, m directed edges and no cycle. WNJXYK starts from point 1. For every round, WNJXYK will randomly select one of the directed edges which start from current point with equal possibility, and go to next point by this edge. And the game will continue until such edge doesn’t exist. DIDIDI will place the treasure on point n, if WNJXYK go through this point, he can get the treasure. WNJXYK have one chance to delete one edge(he can also don’t choose to delete), that he can increase the probability of getting a treasure. Your assignment is to calculate the probability of WNJXYK getting the treasure in the optimal condition.

 

Input

The first line of input contains a positive integer T telling you there are T test cases followed.

For each test case, the first line contains two integers n , m, indicating the number of points ,the number of edges.

Then the following are m lines, each of which contains two integers x and y, indicating there is a edge from x to y.

It is guaranteed that there does not exist multiple edge.

 

Output

For each test case, print a line “Case #x: y”, where x is the case number (starting from 1) and y is the probability of he getting the treasure. (round to six decimal places).

 

Sample Input

2
4 4
1 2
1 3
1 4
2 3
4 5
1 2
1 3
1 4
2 3
2 4

 
 
Null

 

Sample Output

Case #1: 0.500000

Case #2: 0.750000

#include<bits/stdc++.h>
using namespace std;
typedef long long  ll;
vector<int>g[53];
vector<bool>g2[53],vis[53];
bool vis1[53];
double ans,dp[53],maxn;
int n,flag=0;
double dfs(int u,double k)
{
    if(vis1[u])return dp[u]*k;
    vis1[u]=1;
    double tmp=0;
    if(u==n)
    {
        dp[u]=1;
        return k;
    }
    if(g[u].size()==0)
    {
        dp[u]=0;
        return 0;
    }
    double t1=0;
    for(int i=0; i<g[u].size(); i++)
    {
        if(vis[u][i]==0)continue;
        t1=dfs(g[u][i],k/(u==flag?g[u].size()-1:g[u].size()));
        if(t1>0)g2[u][i]=1;
        tmp+=t1;
    }
    dp[u]=tmp/k;
    return tmp;
}

int main()
{
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
    int t,cnt=1,m,x,y;
    scanf("%d",&t);
    while(t--)
    {
        maxn=0;
        scanf("%d%d",&n,&m);
        memset(vis1,0,sizeof(vis1));
        for(int i=1; i<=n; i++)g[i].clear(),g2[i].clear(),dp[i]=0,vis[i].clear();
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d",&x,&y);
            if(x==n)continue;
            g[x].push_back(y);
           vis[x].push_back(1);
            g2[x].push_back(0);
        }
        maxn=max(ans,dfs(1,1));
       // printf("%.6f\n",maxn);
         for(int i=1; i<n; i++)
    {
        for(int j=0; j<g[i].size(); j++)
        {
            if(g2[i][j]==0)
            {
                memset(vis1,0,sizeof(vis1));
                vis[i][j]=0;
                flag=i;
                memset(dp,0,sizeof(dp));
               // cout<<i<<" "<<j<<" "<<dfs(1,1)<<endl;
                maxn=max(maxn,dfs(1,1));
                vis[i][j]=1;
                flag=0;
            }
        }
    }
        printf("Case #%d: %.6f\n",cnt++,maxn);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值