Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Description
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay
atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint
Huge input and output,scanf and printf are recommended.
Source
Waterloo local 2001.09.22
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAXN 100010
struct Lnode{
int next[26];
int IsEnd;
}node[MAXN * 10];
int nNode, n;
char dic[MAXN][15];
void add(char *s, int id){
int i, k;
k = 0;
for (i = 0; s[i]; i++){
if (node[k].next[s[i] - 'a'] < 0){
memset(node[nNode].next, 0xff, sizeof(node[0].next));
node[nNode].IsEnd = -1;
node[k].next[s[i] - 'a'] = nNode++;
}
k = node[k].next[s[i] - 'a'];
}
node[k].IsEnd = id;
}
int find(char *s){
int i, k;
k = 0;
for (i = 0; s[i]; i++){
if (node[k].next[s[i] - 'a'] < 0) break;
k = node[k].next[s[i] - 'a'];
}
if (k > 0 && node[k].IsEnd >= 0) return node[k].IsEnd;
return -1;
}
int readword(char *s){
int i;
i = 0;
while (s[i] = getchar(), s[i] != ' ' && s[i] != '\n') i++;
s[i] = '\0';
if (i == 0) return 0;
return 1;
}
int main(){
char s[15];
int i, j, k;
memset(node[0].next, 0xff, sizeof(node[0].next));
node[0].IsEnd = 0;
nNode = 1;
n = 0;
while(readword(dic[n])){
readword(s);
add(s, n);
n++;
}
while(scanf("%s", s) != EOF){
k = find(s);
if (k < 0) printf("eh\n");
else printf("%s\n", dic[k]);
}
return 0;
}
/*
用Tri树做匹配
ungetc(c, stdin)可以把char再还到输入流中~
*/