hdu 1060 - Leftmost Digit(求N^N最高位)

1 篇文章 0 订阅

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10320    Accepted Submission(s): 3923


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


===========================


借鉴了下别人的思路:

http://blog.csdn.net/lovelyloulou/article/details/5237263


令num^num=10^n *a(科学计数法)
两边取对数: num*lg(num) = n + lg(a);
因为a<10,所以0<lg(a)<1
令x=n+lg(a); 则n为x的整数部分,lg(a)为x的小数部分
a=10(x-n)=10(x-int(x)))
再取a的整数部分即得num的最高位


log(n):以e为底的对数

log10(n):以10为底的对数

以a为底的对数用换底公式:log(n)/log(a)


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

int main()
{
    int t;
    double x;
    long long n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d",&n);
        x=n*log10(n*1.0);
        //cout<<x<<endl;
        x-=(long long)x;
        int a=pow(10.0,x);
        printf("%d\n",a);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值