poj3904 Sky Code

Sky Code
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1694 Accepted: 523

Description

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input

4
2 3 4 5 
4
2 4 6 8 
7
2 3 4 5 7 6 8

Sample Output

1 
0 
34

题意:给定n个数a1,a2,a3,…,an,从中选出四个数,使得他们之间的最大公约数为1,问有多少种取法?

解题思路:对每一个数ai,我们对它进行质因数分解,然后利用2^k算法找出所有由质因数组成的数,并记录组成该数的质因数个数,最后运用容斥原理进行求解;

参考代码:

#include <iostream>
#include <string.h>
using namespace std;
#define MAX_N 10000+5
#define MAX_FACTOR 16
typedef long long ll;
int n,f[MAX_N],count[MAX_N],factor[MAX_FACTOR],factor_num[MAX_N];
void solve(int a){
	int k=0;
	for (int i=2;i*i<=a;i++){	//质因数分解
		if (a%i==0){
			factor[k++]=i;
			while (a%i==0)
				a/=i;
		}
	}
	if (a>1)
		factor[k++]=a;
	for (int i=1;i<(1<<k);i++){	//2^k算法
		int mul=1,bits=0;
		for (int j=0;j<k;j++){
			if (i&(1<<j)){
				bits++;
				mul*=factor[j];
			}
		}
		count[mul]++;
		factor_num[mul]=bits;
	}
}
ll cal(ll a){
	return a*(a-1)*(a-2)*(a-3)/24;
}
int main(){
	while (cin>>n){
		for (int i=0;i<n;i++)
			cin>>f[i];
		memset(count,0,sizeof(count));
		memset(factor_num,0,sizeof(factor_num));
		for (int i=0;i<n;i++)
			solve(f[i]);
		ll ans=cal(n);
		for (int i=2;i<=10000;i++){
			if (factor_num[i]&1==0){
				ans+=cal(count[i]);
			}
			else{
				ans-=cal(count[i]);
			}
		}
		cout<<ans<<endl;
	}
		
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值