POJ 3904 Sky Code(容斥)

38 篇文章 0 订阅

Description

Stancu likes space travels but he is a poor software developer and will never be able to buy his own spacecraft. That is why he is preparing to steal the spacecraft of Petru. There is only one problem – Petru has locked the spacecraft with a sophisticated cryptosystem based on the ID numbers of the stars from the Milky Way Galaxy. For breaking the system Stancu has to check each subset of four stars such that the only common divisor of their numbers is 1. Nasty, isn’t it? Fortunately, Stancu has succeeded to limit the number of the interesting stars to N but, any way, the possible subsets of four stars can be too many. Help him to find their number and to decide if there is a chance to break the system.

Input

In the input file several test cases are given. For each test case on the first line the number N of interesting stars is given (1 ≤ N ≤ 10000). The second line of the test case contains the list of ID numbers of the interesting stars, separated by spaces. Each ID is a positive integer which is no greater than 10000. The input data terminate with the end of file.

Output

For each test case the program should print one line with the number of subsets with the asked property.

Sample Input

4
2 3 4 5 
4
2 4 6 8 
7
2 3 4 5 7 6 8

Sample Output

1 
0 
34

题目大意

在 n 个数中统计gcd(a,b,c,d)=1的个数。

解题思路

可以用总的情况,减去gcd(a,b,c,d)!=1的情况,总的情况即为 C4n ,关键是gcd(a,b,c,d)!=1的求法。
通过对 n 个数进行质因子分解,然后统计出所出现的素因子的总个数,假如 2 出现的次数总共为 a,那么代表在 n 个数中有 a 个数含有质因子 2 ,则有 Ca4 个组合的gcd等于2,其它数同理,则根据容斥原理便可求出所有gcd不为 1 的情况,如 2 出现次数总共为 a,3 出现次数总共为 b,6出现次数总共为 c,那么此时总的gcd!=1的情况是 Ca4+Cb4Cc4

代码实现

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 10007
#define ll long long
int countt[maxn],num[maxn];
int prime[maxn],n;
ll a[maxn];
void init()
{
    memset(a,0,sizeof(a));
    for(ll i=4;i<maxn;i++)
        a[i]=i*(i-1)*(i-2)*(i-3)/24;
}
void solve(int m)
{
    int t=0;
    for(int i=2; i*i<=m; i++)
    {
        if(m%i==0)
            prime[t++]=i;
        while(m%i==0)
            m/=i;
    }
    if(m!=1)
        prime[t++]=m;
    for(ll i=1; i<(1<<t); i++)
    {
        int k=1;
        int sum=0;
        for(ll j=0; j<t; j++)
        {
            if(i&(1<<j))
            {
                k*=prime[j];
                sum++;
            }
        }
        countt[k]++;
        num[k]=sum;
    }
}

int main()
{
    init();
    while(~scanf("%d",&n))
    {
        memset(countt,0,sizeof(countt));
        memset(num,0,sizeof(num));
        int m;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&m);
            solve(m);
        }
        ll ans=0;
        for(int i=0;i<maxn;i++)
        {
            if(countt[i])
            {
                if(num[i]%2)
                    ans+=a[countt[i]];
                else
                    ans-=a[countt[i]];
            }
        }
        printf("%lld\n",a[n]-ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值