Description
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.
You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
Input
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
Output
For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
Sample Input
2 12.5 5 0:23:21 0:25:01 42 0:23:32 -:--:-- 7 0:33:20 0:41:35
Sample Output
5: 3:52 min/km 42: - 7: 6:00 min/km
用了一晚上才做出来,这题就是个坑啊坑啊!
其实就是让算平均值,只要注意了格式根本没有挑战性,但是就是因为第29行那个continu我为了节省循环换为了break;,留下了祸根啊,别想等我调了一晚上都换了好几个算法之后发现就是一个break之后,上万只草泥马在心中狂奔的心情啊。
#include <stdio.h>
int main()
{
int tn;
double len;
int h,m,s;
int i;
double tim;
int no;
scanf ("%d%lf",&tn,&len);
while (~scanf ("%3d",&no))
{
char str[100];
char *p;
int tf = 1;
tim = 0;
for (i = 0; i < tn; i++)
{
h = 0,m = 0,s = 0;
scanf ("%s",str);
p = str;
if (*p == '-')
{
tf = 0;
continue;
}
int q = 1;
while (*p != ':')
{
h = h * q + (*p - '0');
q *= 10;
p++;
}
p++;
q = 1;
while (*p != ':')
{
m = m * q + (*p - '0');
q *= 10;
p++;
}
p++;
q = 1;
while (*p != '\0')
{
s = s * q + (*p - '0');
q *= 10;
p++;
}
tim += (h * 3600) + (m * 60) + s;
}
if (tf)
{
int itim = tim / len + 0.5;
printf ("%3d: %d:%02d min/km\n",no,itim/60,itim%60);
}else
printf ("%3d: -\n",no);
}
return 0;
}