2014ACM集训13级PK赛4-Light Bulb

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.0000.7504.000

 

 

先分类讨论,因为影子存在两种情况,一种是全部影子在地上,一种是一部分影子在地上,一部分在墙上。

那么,如果影子全部在地上,那么,根据常识,那么L一定是恰好为0,那么根据三角形像似,很容易就能求出这个值。

第二种情况,就是L存在那么,影子的长度就成了一个两部分组成,如果设做墙角到人的距离为X,那么L就可以根据三角形像似写的一个与X有关的函数。

对函数求最大值,再熟悉不过了,求导啊。然后就能得到第二种情况的最大值。

然后两个最大值进行比较,就OK了。

ps'有同学直接判断影子在墙上才会出现最大值,然后加减0.00001暴力居然也A了。

#include <string.h>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>

int main()
{
    int N;
    scanf ("%d",&N);

    while (N--)
    {
        double H,h,D;
        scanf ("%lf%lf%lf",&H,&h,&D);
        double dmax = (h / H) * D;

        double tmp = sqrt(D * (H - h));//求导;

        if(tmp > D)
            tmp = D;
        if(tmp < (D * (H - h) / H))
            tmp = D * (H - h) / H;

        tmp = D + H - tmp - (H - h) * D / tmp;
        if(tmp > dmax)
            dmax = tmp;

        printf ("%.3lf\n",dmax);
    }
    return 0;
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值