HDU 4461 The Power of Xiangqi

The Power of Xiangqi

Xiangqi is one of the most popular two-player board games in China. The game represents a battle between two armies with the goal of capturing the enemy’s “general” piece.
Now we introduce some basic rules of Xiangqi. Xiangqi is played on a 10×9 board and the pieces are placed on the intersections (points). There are two groups of pieces marked by black or red Chinese characters, belonging to the two players separately. During the game, each player in turn moves one piece from the point it occupies to another point. No two pieces can occupy the same point at the same time. A piece can be moved onto a point occupied by an enemy piece, in which case the enemy piece is “captured” and removed from the board. When the general is in danger of being captured by the enemy player on the enemy player’s next move, the enemy player is said to have “delivered a check”. If the general’s player can make no move to prevent the general’s capture by next enemy move, the situation is called “checkmate”.
Each player has 7 kinds of pieces in this game. Their names, offense power and symbol letters are shown in the table below:
这里写图片描述

Now show you the pieces of red player and black player, you are going to find out which player has the larger total offense power. Since Ma and Pao working together can have good effect, if a player has no Ma or no Pao, or has neither, his total offense power will be decreased by one. But the total offense power can’t be decreased to zero, it is at least one.

Input

The first line is an integer T ( T <= 20) meaning there are T test cases.
For each test case: The first line shows which pieces the red player has. It begins with an integer n ( 0 < n <= 16) meaning the number of pieces.
Then n letters follows, all separated by one or more blanks. Each letter is a symbol letter standing for a piece, as shown in the table above.
The second line describes the situation of the black player, in the same format as the first line.

Output

For each test case, if the red player has more offense power, then print “red”. If the black player has more offense power, then print “black”. If there is a tie, print “tie”.

Sample Input

3
2 A B
2 A B
7 A A B C D D F
7 A A B B C C F
5 A A B B F
3 A B F

Sample Output

tie
black
red


题目比较简单,累加求和比较大小,唯一需要注意的是如果没有A或者没有B,或者两个都没有,则总数要减去1

AC

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        char x,y;
        int r,b;
        int sum_red=0;
        int sum_black=0;
        int flagb=0,flagc=0;
        cin>>r;
        for(int i=0; i<r; i++)
        {
            cin>>x;
            if(x=='A')
                sum_red+=16;
            else if(x=='B')
            {
                sum_red+=7;
                flagb++;
            }
            else if(x=='C')
            {
                sum_red+=8;
                flagc++;
            }
            else if(x=='D')
                sum_red+=1;
            else if(x=='E')
                sum_red+=1;
            else if(x=='F')
                sum_red+=2;
            else if(x=='G')
                sum_red+=3;
        }
        if(flagb==0||flagc==0&&sum_red>1)
            sum_red-=1;
        flagb=0;
        flagc=0;
        getchar();
        cin>>b;
        for(int i=0; i<b; i++)
        {
            cin>>y;
            if(y=='A')
                sum_black+=16;
            else if(y=='B')
            {
                sum_black+=7;
                flagb++;
            }
            else if(y=='C')
            {
                sum_black+=8;
                flagc++;
            }
            else if(y=='D')
                sum_black+=1;
            else if(y=='E')
                sum_black+=1;
            else if(y=='F')
                sum_black+=2;
            else if(y=='G')
                sum_black+=3;
        }
        if(flagb==0||flagc==0&&sum_black>1)
            sum_black-=1;
        if(sum_red==sum_black)
            cout<<"tie"<<endl;
        else if(sum_red>sum_black)
            cout<<"red"<<endl;
        else if(sum_red<sum_black)
            cout<<"black"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值