1046 Shortest Distance (20 point(s))
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by Ninteger distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
简单模拟。
常规方法会超时(case#2不能通过,17分),用hashTable初始化sum[],记录从1到i+1的元素和,为后面的每次询问准备,减小复杂度。
TLE总结:1. 采用scanf、printf输入输出;2. 空间换时间。特别是查询问题(本题)、素数筛法等。
#include<iostream>
using namespace std;
const int N = 1e5+7;
int num[N]={0};int sum[N]={0};int n;
void init(){
for(int i=1;i<=n;i++) sum[i]=sum[i-1]+num[i];//sum[i] 从1到i+1的距离
}
int shortdis(int p1,int p2){
if(p1==p2) return 0;
if(p1>p2){
int tmp = p1;p1 = p2;p2 = tmp;
}
int a1 = sum[p2-1]-sum[p1-1];
int a2 = sum[n]-a1;
return a1>a2?a2:a1;
}
int main(void){
int m,p1,p2;cin>>n;
for(int i=1;i<=n;i++) cin>>num[i];
init();
cin>>m;
while(m--){
cin>>p1>>p2;
int ans = shortdis(p1,p2);
cout<<ans<<endl;
}
return 0;
}