1101 Quick Sort (25 point(s))

 1101 Quick Sort (25 point(s))

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then the next line contains N distinct positive integers no larger than 10​9​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

题意:可以作为pivot的元素满足条件:在它之前的元素都小于它,在它之后的元素都大于它。

思路:动态规划思想。使用两个数组,采用两次循环,分别标记每一个元素是否满足这两个要求。如果都满足,则可以输出。

注意点:最后需要输出换行符,否则case#2会PE(22分)。

#include<iostream>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int MAX = 1e5+7;
int a[MAX];
bool leftPivot[MAX]={false};
bool rightPivot[MAX]={false};
int main(void){
	int N;cin>>N;
	for(int i=0;i<N;i++) cin>>a[i];
	int curMax,curMin;
	for(int i=0;i<N;i++){
		if(i==0){
			curMax = a[i];
			leftPivot[i]=true;
		}
		else if(i>0&&a[i]>curMax){
			leftPivot[i]=true;
			curMax = max(curMax,a[i]);
		}
	}
	for(int i=N-1;i>=0;i--){
		if(i==N-1){
			curMin = a[i];
			rightPivot[i]=true;
		}
		else if(i<N-1&&a[i]<curMin){
			rightPivot[i]=true;
			curMin = min(curMin,a[i]);
		}
	}
	vector<int> v;
	for(int i=0;i<N;i++){
		if(rightPivot[i]&&leftPivot[i]) v.push_back(a[i]);
	}
	cout<<v.size()<<endl;
	for(int i=0;i<v.size();i++){
		if(i==0) cout<<v[i];
		else cout<<" "<<v[i];
	}
	cout<<endl;
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值